V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
xuwenchao
V2EX  ›  iOS

个人 iOS APP ,大家会选择兼容到哪个版本?

  •  
  •   xuwenchao · 21 天前 · 2500 次点击

    https://developer.apple.com/support/app-store/ 如题,现在 17 、16 占大比例,对于独立开发者来说,大家觉得还有必要兼容到 15 或更低么?

    32 条回复    2024-05-28 09:18:13 +08:00
    thinkm
        1
    thinkm  
       21 天前
    12
    ByZHkc3
        2
    ByZHkc3  
       21 天前   ❤️ 2
    我新的 App 直接 17.1 ,爱用不用,不用 gun done
    Tune
        3
    Tune  
       21 天前   ❤️ 1
    我个人认为还是到 15 好一些吧,因为喜欢折腾软件,爱搞数码的都会停在这个能越狱或者巨魔的版本
    NanFengxuan
        4
    NanFengxuan  
       21 天前
    兼容到 13 呗,SwiftUI 替代 Storyboard 的第一个版本。
    xuwenchao
        5
    xuwenchao  
    OP
       21 天前
    @thinkm 逆天
    xuwenchao
        6
    xuwenchao  
    OP
       21 天前
    @ByZHkc3 潇洒,直接上 SwiftData
    xuwenchao
        7
    xuwenchao  
    OP
       21 天前
    @NanFengxuan 今年才学的 iOS 开发,表示第一次听到 Storyboard Σ(⊙▽⊙"a
    xuwenchao
        8
    xuwenchao  
    OP
       21 天前
    @Tune 学习了,原来还有这种因素
    drymonfidelia
        9
    drymonfidelia  
       21 天前 via iPhone
    12 。抖音最新版都能支持 iOS12
    weeei
        10
    weeei  
       21 天前
    iOS 13 ,发现很多老外个人开发也是,这个版本挺好,可以支持深色模式。
    AlwaysBee
        11
    AlwaysBee  
       21 天前
    SwiftUI 的话,建议 16
    Pichai
        12
    Pichai  
       21 天前 via iPhone
    你出海就要兼容更多一点,看新闻还有一些网友分享,老外使用老设备的比较多!
    magic3584
        13
    magic3584  
       21 天前 via iPhone
    iOS 14 ,支持小组件,iCloud 同步通知
    neptuno
        14
    neptuno  
       21 天前
    @ByZHkc3 是的,我新起了个项目也想直接用 swiftdata ,反正都是 side proj ,自己写的开心最重要
    xiaoshan5733
        15
    xiaoshan5733  
       21 天前
    13.4+
    LINAICAI
        16
    LINAICAI  
       21 天前
    企业基本上和最新版 xcode 最低支持的版本就可以了,但是个人可以高两个版本,14 或者 15 ,毕竟很多新特性可以直接使用。
    yechentide
        17
    yechentide  
       21 天前 via iPhone
    肯定至少 iOS15 以上,因为 StoreKit2 是 iOS15 以上可以用,除非你不弄内购
    beimenjun
        18
    beimenjun  
       21 天前
    你就先做呗,对于新手来说,如果你做 iOS 17 不能做到赚钱,那你做更多更低系统版本的适配其实也赚不了。
    icy37785
        19
    icy37785  
       20 天前 via iPhone
    巨魔支持到哪个版本,就最低兼容到比它高一个版本。
    xuwenchao
        20
    xuwenchao  
    OP
       20 天前
    感谢各位 V 站老哥的建议,小弟心里有底了。👨🏻‍💻
    Maxbee
        21
    Maxbee  
       20 天前
    iOS12
    blaaibla
        22
    blaaibla  
       20 天前 via iPhone
    我是最低 15 ,这个是为了兼容 iPhone7 。学生和第三世界的用户还是非常多,二手 iOS 设备其实寿命非常长。我常用 iOS 设备就有 iPhone7 。
    tbg
        23
    tbg  
       20 天前
    当前最新版本-3
    wangpao
        24
    wangpao  
       20 天前
    取决 app 的功能和面对人群,比我这打算利用 iPad mini2 (最高升级到 12.5.7 ),发现对我来说最适合的就是当副屏,YUM Display 能支持 12 ,这种支持旧系统就很有意义了。
    weeei
        25
    weeei  
       20 天前
    @NanFengxuan 如果搞 SwiftUI ,最低系统需求最好拉到 iOS 16 ,不然解决兼容问题会很痛苦。
    crazyzzm
        26
    crazyzzm  
       20 天前
    如果有特殊需求,系统 API 有版本要求,可以根据 API 适配;
    如果没有,最低版本可以参考微信、抖音之类的,没太多精力的话,可以适当调高些
    llysr1005
        27
    llysr1005  
       20 天前
    最新版, 没有升级的不配用😄
    agagega
        28
    agagega  
       20 天前
    如果你的 App 就是为了直接卖钱,那兼容到 N-1 (比如现在是 17 那就兼容到 16 )就可以了,因为据我观察那种万年不升系统的人,大概率也不会花钱买 App ,这样正好做筛选。

    还有就是你没法保证你的 App 一开始就有多少用户,推广维护的过程可能会伴随新的 iOS 版本,你开始只兼容 16 甚至 17 会显得很激进,但等到 18 出来了慢慢问题就不大了。
    ivyliner
        29
    ivyliner  
       20 天前
    @xuwenchao 根据我多款 SwiftUI 的 app 独立经验 ( https://www.engineerdraft.com/) , 我给你的建议是从 SwiftUI 从 iOS 16 开始支持, 在目前的节点下 16 版本是一个比较好平衡用户群体和开发时间的平衡点.
    xuwenchao
        30
    xuwenchao  
    OP
       20 天前
    @agagega 一针见血
    xuwenchao
        31
    xuwenchao  
    OP
       20 天前
    @ivyliner 经验之谈,get 了
    wowbaby
        32
    wowbaby  
       19 天前
    ios 12, 因为我自己后面买的所有设备都还是出厂系统,包括家人的,坚决不升级,除了 MacBook
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   2449 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 35ms · UTC 15:22 · PVG 23:22 · LAX 08:22 · JFK 11:22
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.