V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
推荐学习书目
Learn Python the Hard Way
Python Sites
PyPI - Python Package Index
http://diveintopython.org/toc/index.html
Pocoo
值得关注的项目
PyPy
Celery
Jinja2
Read the Docs
gevent
pyenv
virtualenv
Stackless Python
Beautiful Soup
结巴中文分词
Green Unicorn
Sentry
Shovel
Pyflakes
pytest
Python 编程
pep8 Checker
Styles
PEP 8
Google Python Style Guide
Code Style from The Hitchhiker's Guide
drymonfidelia
V2EX  ›  Python

Python 怎么强制安装编译不通过的包?一个包只能在 Linux 下使用,但 Linux 所有桌面环境的 bug 都实在太多,不想用, JB 的那个 Remote 功能也很不稳定

  •  1
     
  •   drymonfidelia · 40 天前 · 1570 次点击
    这是一个创建于 40 天前的主题,其中的信息可能已经有所发展或是发生改变。

    想在 Windows 下开发 Linux 调试,如果不装包的话就没有代码提示

    14 条回复    2024-04-26 00:02:31 +08:00
    ysc3839
        1
    ysc3839  
       40 天前 via Android
    pypi.org 搜索包,然后在 Download files 里面找最接近你系统的 whl 包,下载后 pip install 即可。
    如果没有适合你系统的 whl 包,那就必须编译。
    drymonfidelia
        2
    drymonfidelia  
    OP
       40 天前 via iPhone
    @ysc3839 我想要强行安装一个运行不了的,来启用代码提示
    bianhui
        3
    bianhui  
       40 天前
    如果不是 python 源码安装,肯定用不了的依赖的动链类型都不一样,可以安装一个 wsl2 ,在其中进行调试。windows 进行开发
    ysc3839
        4
    ysc3839  
       40 天前
    @drymonfidelia 可以下载 whl 后解压出来
    AlexShui
        5
    AlexShui  
       40 天前   ❤️ 1
    pip freeze >requirement.txt
    pip download -r .\requirement.txt -d ./pip_package
    jjx
        6
    jjx  
       40 天前   ❤️ 1
    这个, 为什么不用 vscode remote
    jjx
        7
    jjx  
       40 天前
    @jjx 没打全 vs code remote wsl + wsl2 有什么问题吗
    keakon
        8
    keakon  
       40 天前
    vscode remote 每次打开远程项目都要装一堆东西,不知道是不是我的配置问题,所以现在都尽量本地开发=。=
    NessajCN
        9
    NessajCN  
       40 天前
    我建议你这么提问:
    请问 xxx (原包名) 如何在 Windows 下使用?
    而不是像标题这么提问。
    因为你预设了一种自己搞不定的解决方法,然后针对你自己的预设方法来提问
    但可能完全有更适当的解决方法
    Muniesa
        10
    Muniesa  
       40 天前 via Android
    要自己改 setup.py 吧,把编译的部分去掉
    gray0
        11
    gray0  
       40 天前
    强制安装搞笑呢,用 docker 或者 wsl 啊 ····在 docker 里开个 python 环境 ,给你 docker compose 文件 ,直接 docker compose up -d 就起来了

    services:
    python_base:
    image: python:3.11.9-slim-bookworm
    command: /bin/bash
    tty: true
    gray0
        12
    gray0  
       40 天前
    建议用 vscode 的 dev containers 或者 vscode-wsl 处理这种环境问题, 如果你会 python 但不会用 vscode 那真的太可惜了
    tomczhen
        13
    tomczhen  
       40 天前
    这个简单,找巨硬或者厨子帮你兼容一下就行了。毕竟垃圾 Linux DE ,狗都不用 🐶。
    skt041959
        14
    skt041959  
       33 天前
    要补全或者提示的话,不需要安装包,只需要有 stub file 就可以了
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   2673 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 24ms · UTC 14:54 · PVG 22:54 · LAX 07:54 · JFK 10:54
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.