首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
宝塔
V2EX  ›  Linux

现在 CentOS 6 已经落伍了么,昨天想装一个 docker,好像不支持 centos6 的 2.6 版本内核,现在一般都用 Centos 7 了么

  •  
  •   BakCshi · 2016-12-12 13:46:35 +08:00 · 6696 次点击
    这是一个创建于 1073 天前的主题,其中的信息可能已经有所发展或是发生改变。
    有用 vultr 的么,听说 vultr 的 centos 64 位,会占很大的内存,是不是这样
    29 回复  |  直到 2016-12-30 14:21:57 +08:00
        1
    neighbads   2016-12-12 14:02:06 +08:00
    装低版本 docker 呗
        2
    nichijou   2016-12-12 14:08:49 +08:00
    ```
    top - 06:04:44 up 196 days, 4:09, 1 user, load average: 0.00, 0.01, 0.05
    Tasks: 89 total, 2 running, 87 sleeping, 0 stopped, 0 zombie
    %Cpu(s): 0.0 us, 0.0 sy, 0.3 ni, 99.7 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
    KiB Mem : 758748 total, 126748 free, 133792 used, 498208 buff/cache
    KiB Swap: 0 total, 0 free, 0 used. 455176 avail Mem
    ```
    vultr 的 centos 64bit
    就跑个 ss ,我对数字没什么概念,这算多算少呢
        3
    BakCshi   2016-12-12 14:17:41 +08:00
    @nichijou 你这个是 64 位的么,你这内存还剩 600 多 m
        4
    yuhuan66666   2016-12-12 14:18:14 +08:00 via Android
    @neighbads 低版本的 对于 net 那块只有 link ,没有 7 的方便
        5
    BakCshi   2016-12-12 14:19:44 +08:00
    @neighbads 直接 yum 安装 docker ,装不上,不太确定是 yum 库的问题,还是内核版本的问题。 但是现在 linux 内核 2.6 是不是很老的了,我看都有 4.几的版本了
        6
    BakCshi   2016-12-12 14:20:43 +08:00
    @yuhuan66666 linux 2.6 的内核是不是很老了,支持不太好
        7
    ldrljq   2016-12-12 14:23:48 +08:00
    根本不想用 centos7 的版本,可能是因为用 rhel5/6 比较习惯了。。。
        8
    BakCshi   2016-12-12 14:27:56 +08:00
    @ldrljq 是啊,但是 centos 6 的内核版本感觉有点低,升级也不太方便,熟悉了 6 的 iptables ,网络配置文件。 换成 7 挺别扭的
        9
    9hills   2016-12-12 14:28:41 +08:00
    Docker 需要 3.10+内核,还是用 CentOS 7 吧
        10
    9hills   2016-12-12 14:29:25 +08:00
    @BakCshi 呔,竟敢诋毁我大 systemd
        11
    BakCshi   2016-12-12 14:33:41 +08:00
    @9hills 那还是换 CentOS 7 吧
        12
    helloccav   2016-12-12 14:39:05 +08:00
    我也遇到这个问题,想试试 docker ,发现手头上的 vps 全都是 2.6 内核
        13
    BakCshi   2016-12-12 14:41:12 +08:00
    @helloccav CentOS6 都是 2.6 的,换成 CentOS7 的可以了,但是 CentOS 7 的默认配置完全和 CentOS 6 不一样,比如网络配置、防火墙、 netstat 命令什么的
        14
    est   2016-12-12 14:42:04 +08:00
    docker 的企业级应用场景就是如何给 Centos5 装上 docker
        15
    zaishanfeng   2016-12-12 14:44:13 +08:00
    升级内核呀
        16
    BakCshi   2016-12-12 14:46:00 +08:00
    @est 升级内核吧,我是自己折腾玩,公司没有用 docker
        17
    xucuncicero   2016-12-12 14:47:54 +08:00 via iPhone
    7 早升早好,用起来比 6 爽多了
        18
    9hills   2016-12-12 14:53:05 +08:00
    @est 6 升级内核后可以, 5 实在是老的厉害
        19
    est   2016-12-12 15:51:19 +08:00
    @BakCshi
    @9hills

    都用 centos 了。 SA 会擅自升级内核么。。。企业级重要的是稳定。 Python 2.4 要再用 20 年才行。
        20
    way2exp   2016-12-12 15:59:50 +08:00
    哎~ 难道都不知道内核可以单独升级么?@zaishanfeng
        21
    peneazy   2016-12-12 17:57:45 +08:00
    早点用 7 吧,出来也都 3 年了 鸟哥的最新版书都是用 7 讲的
        22
    BakCshi   2016-12-12 18:41:21 +08:00
    @peneazy 公司基本都还是 CentOS 6 呢
        23
    zizifu   2016-12-12 18:43:15 +08:00
    centos 7 才支持 docker engine
        24
    iCyMind   2016-12-13 08:31:56 +08:00 via Android
    把 firewalld 切换回 iptables 也就几条命令
        25
    jyf007   2016-12-13 08:58:52 +08:00 via Android
    openvpn/lxc 算不算
        26
    lxguidu   2016-12-13 09:22:15 +08:00
    CentOS 6 肯定落伍啦,这么多年了。
        27
    ltye   2016-12-13 10:59:45 +08:00
    官方不对 6 系列做支持, 6 升内核后装的 docker 稳定性及其他的坑未知。既然要用 docker ,升级个操作系统也不是多大的事吧, systemd 也挺好用的。
        28
    tinyproxy   2016-12-13 14:05:06 +08:00
    要用 docker 建议用 ubuntu ,不要上 centos , 15 年在 centos 上面装过,有时候莫名其妙就 kernel panic 了,换完 ubuntu 跑到现在都没啥问题。
        29
    wdzawl   2016-12-30 14:21:57 +08:00
    升级系统内核到 3.10 就可以了 但是 docker 的版本是 1.7 的
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3916 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 28ms · UTC 09:45 · PVG 17:45 · LAX 01:45 · JFK 04:45
    ♥ Do have faith in what you're doing.