V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
cheneydog
V2EX  ›  问与答

PVE 7.2-3 安装 ceph 报错

  •  
  •   cheneydog · 59 天前 · 318 次点击
    这是一个创建于 59 天前的主题,其中的信息可能已经有所发展或是发生改变。

    提示说是 python3 版本太高了。怎么办,总不能卸载 python3 吧,会连带着卸载更多东西的。

    The following packages have unmet dependencies:
     ceph-base : Depends: ceph-common (= 15.2.15-pve1~bpo10) but 15.2.16-pve1 is to be installed
                 Recommends: btrfs-tools
                 Recommends: librados2 (= 15.2.15-pve1~bpo10) but 15.2.16-pve1 is to be installed
                 Recommends: libradosstriper1 (= 15.2.15-pve1~bpo10) but 15.2.16-pve1 is to be installed
                 Recommends: librbd1 (= 15.2.15-pve1~bpo10) but 15.2.16-pve1 is to be installed
     python3-cffi-backend : Depends: python3 (< 3.8) but 3.9.2-3 is to be installed
     python3-distutils : Depends: python3 (< 3.8) but 3.9.2-3 is to be installed
                         Depends: python3-lib2to3 (>= 3.6.4) but it is not going to be installed
     python3-markupsafe : Depends: python3 (< 3.8) but 3.9.2-3 is to be installed
    
    2 条回复    2022-06-28 21:05:47 +08:00
    hanssx
        1
    hanssx  
       45 天前
    这是自带的版本高了吗?
    cheneydog
        2
    cheneydog  
    OP
       45 天前
    解决了,是因为我换了软件源导致的。
    @hanssx
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1055 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 44ms · UTC 20:24 · PVG 04:24 · LAX 13:24 · JFK 16:24
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.