首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
宝塔
V2EX  ›  MacBook Pro

MBP 374(2010)更新 Mavericks 之后频繁假死

  •  
  •   majunbo · 2014-03-17 22:44:23 +08:00 · 4934 次点击
    这是一个创建于 2070 天前的主题,其中的信息可能已经有所发展或是发生改变。
    星期六换的ssd硬盘,安装了osx 10.9.2就一直在假死,稍微打一个小程序,比如qq或是safair就假死那里了,要死30秒以上不能动。烦死了,到底是怎么回事?
    之前的10.6.8从来没有出现过死机的情况,我对mac还是很信任的,是不是10.9.2的问题?或者在哪里可以年到日志信息之类的?
    第 1 条附言  ·  2014-03-21 15:23:53 +08:00
    问题最终解决,解决方案为:更换成镁光sata3 6gssd硬盘。
    详细测试结果见楼主douban图片。
    在此特别感谢@ultragtx
    39 回复  |  直到 1970-01-01 08:00:00 +08:00
        1
    shinwood   2014-03-17 22:51:09 +08:00   ♥ 1
    同 374 路过,稳定运行中,一般一周关机一次,不过我是格盘重新安装的,不知道与这个有没有关系。
        2
    leadfast   2014-03-17 23:41:05 +08:00   ♥ 1
    374 +1 不过没升SSD,之前装了罗技鼠标的驱动经常五国,卸了现在无任何问题
        3
    pfitseng   2014-03-18 06:53:36 +08:00 via Android   ♥ 1
    374 没问题
        4
    majunbo   2014-03-18 07:00:49 +08:00 via iPhone
    我把老硬盘拆了,新的SSD格式化后全新安装。
    新系统安装之后没有安装其他驱动之类的,本来我以为是系统默认索引问题,今天再用用试试吧。
        5
    jedicxl   2014-03-18 08:04:09 +08:00 via iPhone   ♥ 1
    需要全新安装,直接升级会各种问题
        6
    majunbo   2014-03-18 09:05:24 +08:00
    @jedicxl 我就是全新安装的,根本没有用原来的硬盘。
    顺便一一感谢楼上各位的回复。
        7
    MrMario   2014-03-18 09:19:37 +08:00 via iPhone
    新的294升级10.9.2后各种假死,烦死了……
        8
    sxyclint   2014-03-18 09:34:30 +08:00
    原先升级过Lion或是Mountain Lion没有?如果10.6.8正常,直升10.9.2
        9
    sxyclint   2014-03-18 09:35:01 +08:00
    晕,居然发出去了,有可能是显卡问题,这代显卡有缺陷
        10
    majunbo   2014-03-18 09:39:13 +08:00
    @sxyclint 没有,直接使用的全新硬盘,根本没有用过10.6.7 or 10.6.8,全新格式化后安装的10.9.0然后在线更新的10.9.2
        11
    xiaolanger   2014-03-18 09:53:58 +08:00 via iPhone
    显卡缺陷的话应该是直接六国 你那是什么样?
        12
    ultragtx   2014-03-18 10:18:03 +08:00 via iPad   ♥ 1
    用活动监视器看一下IO的线 看看卡死的时候 IO是不是0 是0就没解了 ssd换回hdd吧
        13
    zhouhua97   2014-03-18 10:49:41 +08:00
    俺的374还是稳定的运行10.7好了,就不折腾了,呵呵。上了8G内存和SSD,性能不错懒得动了。
    倒是回去把760升级看看。
        14
    majunbo   2014-03-18 11:09:21 +08:00
    @ultragtx 如果IO是0是什么问题?ssd无法读写?你碰到过这种情况吗?
        15
    ultragtx   2014-03-18 12:07:59 +08:00 via iPad
    @majunbo 我只见过在11年mbp的光驱位 会有几率遇到我说的这个问题 原因就是sata 6G/s的ssd跑在sata 3G/s上
        16
    majunbo   2014-03-18 13:54:10 +08:00
    @ultragtx 我是SataIII跑在了SataII上没错,不过我安装到了硬盘位置上。
    你的意思这跟硬盘接口有关系,不是盘质量问题?
        17
    inee   2014-03-18 14:55:21 +08:00
    假死的话,应该是驱动之类的问题
        18
    sxyclint   2014-03-18 14:58:49 +08:00
    @xiaolanger
    我之前的显卡问题从来没出过六国,从10.6.8升级间歇性直接死掉,然后重启,去了苹果店,第一个硬件测试都没通过。

    @majunbo
    不是,我的意思是你电脑是不是一直都在用10.6.8,如果是,且升级到10.7+的版本以后就出现死机,很大可能上是遇到了2010年mbp的显卡门,具体情况请看: http://support.apple.com/kb/TS4088?viewlocale=zh_CN 不过374是13还是15的忘了,不过应该是320或是330的显卡
        19
    xiaolanger   2014-03-18 15:03:24 +08:00
    @sxyclint 你试试软件 gfxCardStatus
        20
    majunbo   2014-03-18 15:17:53 +08:00
    @sxyclint 嗯,我明白你的意思。我一直在用10.6.8,没有升级过。10.9.2是新硬盘全新安装。你给我看到这个是“间歇性黑屏或无视频“,我的也是NVIDIA GeForce 320M显卡,我是系统假死,死10秒左右或是10秒以上。
    我的电脑是有@ultragtx 说的io机死的时候读写为0的情况。
        21
    327beckham   2014-03-18 15:59:17 +08:00
    我也是374,两个月前换的SSD,10.9.2没有任何问题,一直都很OK
        22
    majunbo   2014-03-18 16:05:53 +08:00
    @327beckham 兄弟你换的哪一款ssd,给个型号呗,我也换一下。
        23
    byron   2014-03-18 16:57:57 +08:00
    SSD是不是镁光的?
    我的也是同样的情况,最后怀疑是SSD问题。
        24
    ultragtx   2014-03-18 17:03:38 +08:00   ♥ 1
    应该算是兼容性问题
    另外明确一下 我说的io是0 在没死的情况下多少有io波动 到了假死的时候 io是一条直线0 \最好用那个black magic或者别的什么测磁盘速度的软件跑一下 把io占满 如果中途假死 看io线是不是从一个高点 直接跳到0 并在整个假死状态中保持0
        25
    majunbo   2014-03-18 17:44:58 +08:00
    @byron 不是,是KINGSTON SV200S3128G

    @ultragtx 我也是假死后就io线一直是0,我自己上午看了,有7\8次问题的时候都是直线并保持在0大概10秒以上。我今天晚上一会用你说的black magic跑一下。
        26
    327beckham   2014-03-18 18:33:01 +08:00
    @majunbo 我换的是三星的EVO系列的 256GB的。是在新蛋网买的。
        27
    majunbo   2014-03-18 21:19:14 +08:00
    @ultragtx 你好,我做了数据测试,并保存了图片: http://www.douban.com/photos/album/127218576/


    @327beckham 我看了看你的是SATAIII 6G的,没问题是吧。那估计就是kingston和374有兼容问题了。
        28
    ultragtx   2014-03-18 22:51:04 +08:00
    io要能保持读写都是0一段时间 并且在这段时间是假死的 就应该是我说的那个现象 不过我那个是在2011mbp上遇到的 如果有可能的话 最好能单独测试一下ssd是不是没问题 换别的牌子ssd在你机器上试 才能准确知道是哪个环节的问题

    另外也有人说假死也可能是内存或者其他问题 尝试测一下内存 重置一下SMC PRAM什么的

    或者你要不要挣扎一下 把ssd放在光驱位试试
        29
    haoji   2014-03-18 23:25:51 +08:00
    @xiaolanger 2010年中 MBP,显卡缺陷,六国,现在还有什么解决方案吗?
        30
    majunbo   2014-03-19 08:30:28 +08:00 via iPhone
    @ultragtx 早就重置SMC PRAM,原来的系统好好的,肯定是SSD或者系统问题。我今天把硬盘退掉了,换其他品牌。

    谢谢大家帮忙!
        31
    xiaolanger   2014-03-19 18:26:35 +08:00
    @haoji 你确定经常直接就六国了? 你试试gfxCardStatus 用老版本的
        32
    killpanda   2014-03-21 16:44:09 +08:00
    虚拟内存是不是被禁用了?
        33
    majunbo   2014-03-21 17:21:31 +08:00
    @killpanda 应该不是,上次和本次安装过程一样:
    bogon:~ aaa$ sysctl vm.swapusage
    vm.swapusage: total = 1024.00M used = 0.00M free = 1024.00M (encrypted)
        34
    killpanda   2014-03-21 18:57:31 +08:00
    @majunbo 哦 好吧 我有一阵是一开虚拟机就卡死 后来发现是因为虚拟内存被禁用的缘故
        35
    haoji   2014-03-25 12:26:14 +08:00
    @xiaolanger 嗯。经常直接六国。已经关闭 gfxCardStatus,同时系统偏好设置里面的显卡自动切换也关了。
        36
    xiaolanger   2014-03-26 11:00:38 +08:00
    @haoji 是用的老版本的吧? 新版本的还是会自动转换 解决问题了吗?
        37
    haoji   2014-03-26 12:19:55 +08:00
    @xiaolanger 没有。关闭 gfxCardStatus,关闭系统的显卡自动切换。还是会时不时来一下(直接六国)。不过没那么频繁。
        38
    xiaolanger   2014-03-26 12:49:03 +08:00
    @haoji 那就直接用gfxCardStatus省事了啊
        39
    haoji   2014-03-26 23:08:31 +08:00
    @xiaolanger 还没说明白?用它和用系统自动切换,六国几率都很高;都关闭的话,稍微好点。基本可以确定是显卡问题
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1494 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 29ms · UTC 00:50 · PVG 08:50 · LAX 16:50 · JFK 19:50
    ♥ Do have faith in what you're doing.