首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
华为云
V2EX  ›  topthink  ›  全部回复第 1 页 / 共 3 页
回复总数  42
1  2  3  
@wo642436249 具体什么问题?
42 天前
回复了 lp7631010 创建的主题 PHP thinkphp5.1 关联预载入的一个 bug?
@lp7631010 关于关联操作部分 建议首先阅读下官方的掌握数据库和模型的教程 会说的比较详细一些
42 天前
回复了 lp7631010 创建的主题 PHP thinkphp5.1 关联预载入的一个 bug?
抱歉 这是官方文档的失误,我已经修正文档了,因为指定属性的时候必须包含关联键。其实没有必要这样操作,规范的建议是在输出的时候使用 hidden 隐藏。
@gouchaoer2 定位不同,TP 不是一个基于 swoole 或者 workerman 的框架,作为一个 HttpServer 并没有过多要求,有没有协程也不影响,而且很多开发过程需要注意的是应用自身开发需要注意的 和框架并无直接关系。不过扩展本身还会不断完善支持,这只是扩展第一个版本。
很好奇怎么封的 试下 https://www.kancloud.cn 有没有被封 每个文档都有 git 地址 除非把 git 服务也都封了
挺棒的,支持~
@flyshu
@silverpeak
感谢支持,5.1 仍然在持续改进和优化中,比 5.0 更好用~
@abccccabc 5.1 除了不是基于 PHP7 开发的(但是是兼容 PHP7+的 最近发现 PSR 库都还是基于 PHP5.4+ 很让人无语) 其它的特性其实基本都不缺了,是一个非常建议的版本。我们之所以还在不断打磨和改进 5.1 的细节,是希望把 5.1 做成一个长期支持的版本,所以把原先计划在 5.2 引入的一些特性提前在 5.1 实现,无论是性能、稳定性还是功能和开发效率上都能满足,能作为一个实用性很强的框架。事实上,现在用 3.2 的用户还有很多,在他们眼中,其实功能已经够用,而且足够简单。至于 5.2 版本定位 PHP7.1+,但不会盲目追求新技术(至少核心没有这个必要),可能更加关注整个生态的建设,一个框架本身不会牛 B 到天上去的,我们也没这个野心和水平(放眼望去,国内的牛人太多了,V2 就藏龙卧虎),我们只是希望做好自己能做的事情,真正能够给开发者带来帮助的是有大量的贡献者参与贡献,并催生这个生态的成熟。而这个正是国内开源项目最大的欠缺,或者是我们的姿势不对^_^
@NEETLEE 感谢支持,其实这个时候不妨考虑 5.1 比 5.0 更规范更好用哇,尤其是路由这块~
@t2doo Request 对象是容器中单例的 不能自己创建,大多数场景都是依赖注入就行了
@DavidNineRoc 抱歉,并非推广文(其实确实很少推广,时间都花在更新和技术支持上了),而是版本更新贴子而已,特性在官方的开发手册中会说的比较详细一些~
话说,我很少在 V2 上面看到排版特别好看的技术文章,也许是 v2 的编辑器不是特别容易排版吧
这世界上不会只有 Laravel 一个框架,也没有完美的框架,存在即是价值。没有真正用过就不要随便去指指点点其它框架,Laravel 的路由根本不能和 TP5 的路由同日而语~
99 天前
回复了 elarity 创建的主题 PHP 写了一些比较少见的 PHP 教程,欢迎指正批评
@Junjunya 整合目前的框架肯定是不太容易的 但规划好也是有可能更方便的 框架也有改进的空间的 我的希望是官方内核做一些改进后面能尽量简单一些

@elarity 嗯,可以提供参考或者交流 我们有计划对下一个版本 改进下对 workerman 或者 swoole 的支持
99 天前
回复了 elarity 创建的主题 PHP 写了一些比较少见的 PHP 教程,欢迎指正批评
@elarity 我会转载到看云 不过你也可以认领后面 如果需要的话 作为电子书的方式 方便用户阅读
另外关于 tp5 和 workerman 的整合 以后多多探讨
99 天前
回复了 elarity 创建的主题 PHP 写了一些比较少见的 PHP 教程,欢迎指正批评
楼主,支持转载不:) 这种教程对于很多 PHP 开发者还是有用处的
国内还有看云呢 git+md
@abccccabc 5.0 版本主要是修正 BUG 和安全更新了 基本上不太会加功能了,最多是一些优化改进。目前主要更新版本是 5.1 的 ,也是推荐版本
@abccccabc 很抱歉 3.2 已经过了维护和安全更新周期了,官方不会再发布任何版本,不过理论上都可以参考 5.0 版本的来自行改进 PHP7.2 版本并没有什么特别的新特性,没有必要,7.1 版本的类型约束已经足够完善了
@Junjunya 5.2 版本基于 PHP7.1 版本开发和做一些重构,并引入一些新的功能特性
118 天前
回复了 whoam1 创建的主题 程序员 关于学习笔记与知识管理(程序员向)
如果需要 markdown 笔记和阅读支持的话 可以试下 看云 https://www.kancloud.cn ,单页面文档的话用来当博客用也未尝不可~
1  2  3  
关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   实用小工具   ·   2735 人在线   最高记录 3762   ·  
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.1 · 18ms · UTC 05:22 · PVG 13:22 · LAX 22:22 · JFK 01:22
♥ Do have faith in what you're doing.
沪ICP备16043287号-1